Service desk incident page issue
Incident Report for GoToAssist® System Status
Resolved
The issue with GoToAssist Service Desk changing status, assignee and watchlist on Incidents page has been resolved.
We apologize for any inconvenience this may have caused.
Posted 11 months ago. Oct 20, 2016 - 09:14 UTC
Investigating
GoToAssist Service Desk Customers are reporting issues with changing status, assignee and watchlist on Incidents page.
Our engineering team is investigating the issue has a high priority.

We apologize for the inconvenience caused
Posted 11 months ago. Oct 20, 2016 - 08:47 UTC