Servicedesk: Delay sending Emails
Incident Report for GoToAssist® System Status
Resolved
The issue has been resolved and all queues Emails have been delivered. We keep monitoring closely the system and apologize for the inconvenience
Posted 10 months ago. Nov 23, 2016 - 18:27 UTC
Investigating
We currently investigate a delay in sending Emails within our ServiceDesk Product.

We apologize for the inconvenience this may cause
Posted 10 months ago. Nov 23, 2016 - 15:47 UTC